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EMSim is an electrodynamics simulation program. It requires Windows 95 or later to run. It simulates the
motion of electrically charged particles ("test charges") moving through a fixed arrangement of

electromagnetic fields. These freely moving test charges obey the Lorentz force law, F Q(E +v’ B)

\

. . \
and Newton's second law of motion, in the form F = ma.

The resultant forces are summed for each test charge, and an integration process is used to find the test
particle trajectories. The simulation setup allows test charges to optionally interact with each other.

Special Relativity is not taken into account; all interactions are taken to be instantaneous.

Sl base units are used throughout.
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Credits

This work was designed and programmed by Peter Diehr, and submitted in fulfillment of requirements of
PHY 697, a special project in computational physics at Eastern Michigan University, under the supervision of
Dr. Marshall Thomsen. Programming was done using Microsoft Visual Basic 6.0.

Appreciation is expressed to Dr. Weidian Shen for helping me to learn electrodynamics. Thanks are given to
Mark Diehr, for many constructive suggestions on the user interface, and for the development of the icons
and the 3D image of a ball used by the trajectory viewer. Thanks are also given to Steve Swanson for many
discussions of 3D graphics, and to Gary Robinson for much assistance in preparing the help files.

Permission is hereby granted to the Physics Department of Eastern Michigan University, for educational use
of this program. All other rights are reserved to the author, for further information select "About” on the Help
menu (press MA).

Note: "Press “A" means to hold down the CTRL key while pressing the A key.
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Structure of the Simulation

An object model is used throughout the design of EMSim. The main object is the electrodynamics
simulation; the simulation object contains electric fields, magnetic fields, and test charges. The simulation
object has properties such as the current time step size, and the number of simulation steps run. The
simulation object is able to "tokenize" its properties, so that they can be externally saved, and later restored.
The user interface saves the tokenized simulation as a text file with extension .ems.

Each test charge object includes a child electric field object, which holds its charge and current location, as
well as a trajectory history object.

In order to interpret the output of the simulation, the user interface allows you to view the test charge
trajectory histories, or save them for later analysis. Details are given in Simulation Operations below.

Coordinate-free notation fits naturally with the object structure of this simulation. A vector object is used to
implement the mathematical requirements. Internal vector operations always use rectangular coordinates.

The user interface allows the user a free choice of rectangular, cylindrical, or spherical coordinates for all
displays, as well as a choice of degree or radian notation for angles. All values are presented in Sl units.

Mathematical Notation

Parameters of equations appear in bold face type when they appear in the text.

R"( I3) Vectors are denoted by overbar arrows.

A= A‘\/‘A‘\‘ Unit vectorsare denoted by a hat.

\ N | A
<(S- P)‘ A> Bralket notationis used for theinner product.
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Physical Model

Electric fields are defined by EField objects. The field is specified as a point charge of magnitude Q, and its
location R. The field strength at P is then:

N\ 1 Q N\ N
E(P)=——— P- R
P e, ¥ ¥ P-R).

Magnetic fields are defined by BField objects. The orientation of this field is given by a unit vector parallel to
the axis, A, and its location in space is fixed by giving a point S through which the axis passes. By is the field
strength along the axis, and a is a radial decay rate; zero indicates a solenoidal field. The distance from
location P to the axis is given by d:

AP N N\ Ay A NN

R(P)=((S- P)|A)A- (S- P),
/' \/

d =|R(P)|

For a BField object with axis A, axial field strength By, and radial decay constant a, the field strength at P is
then:

B(P) = B, >exp(-a xd) A

Test charges are defined by TestCharge objects, which specify a point charge (magnitude and location),
along with mass and initial velocity. You can also specify whether or not test charges are allowed to interact.

For each step of the simulation, each test charge is requested to tell the net force acting upon it. The test
charge does this by requesting each of the EField, BField, and interacting TCharge objects to calculate the
field at the current location of the test charge. These fields are summed (principle of superposition), and the

Lorentz force law is used to find the net force acting upon this test charge. It the test charge magnitude is Q,
with current velocity v, and location P, then the net force is:

\ \ \ \ \, \ \
Foa(P) =QAE(P)+V" B (P)].
Newton's second law of motion is used to find the acceleration for this test charge of mass m:
\ \ \ \
a(P)=F,(P)/m.

Updated velocity and position for each test charge is then calculated by an integration step. The user has a
choice of Runge-Kutta integration methods.

Page 4



EMSim: Electrodynamics Simulation

Runge-Kutta Integration Formulas

The first order Runge-Kutta integration formula is Euler's method with advanced velocity. After solving
Newton's second law of motion for the acceleration, we simply apply our small time step, h, first to obtain a
new velocity, and again to obtain a new location:

V., =V +hxa(P),
\/ \/
P =P+hx’

The fourth order Runge-Kutta integration formulas are taken from Abramowitz and Stegun, "Handbook of
Mathematical Functions”, section 25.5.20. Though the error term is O(h5) for the position, it is only second
order in the velocity; this is due to the structure of the equations, y"=f(x,y,y'), which requires a double
integration.

The fourth order forms require evaluation at intermediate steps to obtain values KL, k2, k3, and ké:
k1=hxf (X, Yo, o),

k2=hxf(x,+3hy, +3hxy, +5kLy, +7kD),
k3=hxf(x, +3h,y, +3hxy, + kL y, +3k2),
kd=hxf(x, +hy, +hxy +2k3y +k3).

We advance the trajectory by the following formuas

y ., =Y. +h{y +(kl1+k2+k3)/6],

y'n+l = y'n +(k1+2>xk2+2x3+k4)/6.

The application of these formulas to each test charge is done by equating y" to the acceleration of that test
charge, which makes f(x,y,y") the Lorentz force divided by the mass of that test charge.
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Simulation Operations

The program consists of a control panel, a visible log, and a trajectory viewer. The control panel supports:

Loading a simulation from a previously saved .ems file

Saving of the current simulation to an .ems file

Running the current simulation

Restarting the current simulation

Modification of the current simulation

Updating the Field Objects

Saving the trajectory history of the current simulation to a .csv file
Viewing the current activity log

Viewing the current simulation trajectories

Loading a Previously Saved Simulation

You can load a previously saved simulation via the "Open Simulation" option of the File menu (press "O).
This presents a file dialog, and shows the names of available simulations; their file extension is .ems.

Loading a simulation causes the current simulation to be lost. The loaded simulation always starts at step
zero.

Saving the Current Simulation

You can save the current simulation via the "Save Simulation" option of the File menu (press *S). This
presents a file dialog, and shows the names of available simulations; their file extension is .ems. The name
of the current simulation is used as the default file name.
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Running the Current Simulation

m EMSim - Spinners? [_ [7]]

Eile Edit “iewer Help

AR TR 20

Cyl Degrees” Step B1ao Log WiEwer
Simulation Controls:
. 1,400 steps | @0.0010 s/step |  1.4000 s
Yiewer Co-Latitude, Longitude, and Distance:
| 18" | 81° 26 m

The control panel always shows the number of steps taken, the current simulation step size (seconds per
step), and elapsed time in separate panes of a status bar labeled "Simulation Controls". You can change the
step size by clicking on the corresponding pane, or via the "Time per Step" option of the Edit menu (press
AT).

The current integration method is indicated by a check mark on the Edit menu: 1% Order Integrator or 4"
Order Integrator. You can select either via the short cut keys (press “Flor “F4).

To step once through the simulation, press the "Step" tool bar button. Each of the currently active test
charges will "move" the current time step. Their new position will show in the activity log, and on the
trajectory viewer.

To run multiple steps, press the "Run” tool bar button. The caption tells you how many steps it will run. You
can change the number of steps to run by clicking on the "Steps Run" pane of "Simulation Controls”, of via
the "Steps to Run" option of the Edit menu (press *N). A progress bar temporarily replaces the status panes.
After the requested simulation steps have completed, the new positions of each active test charge will show
in the activity log, and on the trajectory viewer.

During the execution of simulation steps, the "Run" button is changed to a "Stop" button. You can press the
"Stop" button to halt the simulation after the completion of the current step. All simulation displays are
updated after that step is completed.

While you may alter any of the simulation parameters whenever the simulation is not running, this may give
non-physical results. However, when used in conjunction with "Restart Current Simulation”, this is very
useful in developing a new electrodynamics simulation.

Restarting the Current Simulation

You can restart the current simulation via the "Restart Current Simulation” option of the Edit menu (press
AR). The restart option resets the step counter and elapsed time to zero, and restores each extant test
charge to the location and velocity it had as of the last time the step counter was zero. All other simulation
parameters remain as they are; this includes the current time step size and integration method, and the
definitions of the electric and magnetic fields.

The "Restart Current Simulation" option allows you to explore systematic changes to parameters while

preserving initial location and velocity. If you wish to restore all parameters, you can reload the simulation
from its .ems file.
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Modifying the Current Simulation

m EMSim - Spinners? [_ [7]]

Eile Edit “iewer Help

AR TR 20

Cyl Degrees” Step B1ao Log WiEwer
—aimulation Controls:
. 1,400 steps | @0.0010 s/step |  1.4000 s
Yiewer Co-Latitude, Longitude, and Distance:
| 18" | 81° 26 m
— Test Charges: —Electric Fields: ~Magnetic Fields: ——

b TO01 W EODT
ek To0? E002

The objects that make up the current simulation are listed by field type. The simulation ignores them unless
the "Status" box is checked; if checked, they are considered to be active.

Right click within the list box to pop up the corresponding option menu: Active/Create/Delete/Update; the
choice (and its corresponding shortcut key sequence) works for the currently selected item within that list
box.

Select "Active" (left click, or press space) to toggle the active state; the simulation ignores inactive objects.

Select "Create" (press Insert) to create a new object; a name will be assigned automatically, and you will be
transferred to its update form.

Select "Remove"” (press Delete) to remove the selected object permanently. If the update form is being
shown, this menu choice is omitted; you must first exit that form.

Select "Update” (press Enter) to transfer you to the update form for the selected object. Multiple update
forms may appear on the screen at the same time; the screen location is considered part of that field's object
description, and is remembered if you save and later restore that simulation. The update forms are not
displayed when a simulation is first loaded; you must do this manually.

Selecting the "Print" menu option (press *P) causes this window to be printed, sans caption.
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Updating the Field Objects

® TOO1-Test Charge E3||  E001-Electric Field B3 [[*>. M001-Magnetic Field

Apply  Miew  Befresh  Print Apply  Miew Hefrezh  Print Apply Miew  Befresh Print
—Status: —Status: — Status:
M [TonT M |EnnT M Moot
e —Charge: - Alpha;
| dooor | |!] _ 0.001 | a
Mass: —Charge location (r.g.2): - B0:

| a3 F] 0 | !

~Interacting? I 0" —dxis of Svmmetry (1.8, 2]
v Include interactions with other I 0
test charges? I £
~ Test Charge location (r.a ) — I 0
I 4217937667951 66 - | I ]
Cance
I 305.44B70R021 7357 —Axis Passes Through (ra.z)—
I -4. 0372591032465 I a
~ Test Charge welocity (v ezl — I 0
I BA7297784342515 I 0

I 112.934303502979°

Cancel |

I -13.8764272344898

| Cancel |

Information is typed directly onto the corresponding update form. Sl base units are used throughout;
reminders appear in the tooltips.

Selecting the "Apply" menu option causes the corresponding object to be updated immediately, even if the
simulation is running. Selecting the "Refresh” menu option causes the current values of the object to be
displayed. This is convenient way to interact with the simulation during its development.

Selecting the "View" menu option allows you to set the line style (including invisible if you need to get a
better view of other trajectories), and line width (press ~F1 through ~F9), as well as color (press *C). Color
can also be modified by pressing the colored button at the bottom of the form to display a color palette; the
selected color is used in the trajectory history viewer.

Selecting the "Print" menu option causes the currently selected window to be printed, sans caption.

Use the toolbar buttons on the control panel to instantly change the coordinate system used for entry and
display; you may choose rectangular, cylindrical, or spherical coordinates, and angles may be presented in
radians or in degrees. Internal storage and calculations are always in rectangular coordinates. You may
notice rounding errors (in about the 14" significant digit) due to the limitations of double precision floating
point, which is used for the storage of coordinates.
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Saving the Trajectory History for the Current Simulation

You can save the current simulation trajectory information via the "Save Trajectory History" option of the File
menu (press "H). This presents a file dialog, and defaults to the name of the current simulation with file
extension .csv.

The current simulation includes a trajectory history for each test charge. This consists of the location and
velocity of that test charge for each time step of the simulation. This can be saved to a .csv file, which is a
text file with quoted strings and comma separated values. The format is suitable for importation into
Microsoft Excel.

After importing the data into Excel, you will see a few rows describing the simulation, followed by a row of
column headings like:

Trajectory History for Simple Cyclotron saved in CAEMSim\Simple Cyclotr
Cylindrical coordinates (deqgrees)

TOD1  [Time |r g z VI v @ v z |Energy
0 1 0 0 1 a0 0 0.5
1 0.02 1] 1.145992 0| 1.00005| 90.5729 0| 0.50005

The first column heading contains the test charge identifier; the simulation step counter is listed in this
column. Missing steps indicate that that test charge was disabled at that time. The next column tells the
elapsed time corresponding to that step.

The next three columns give the position coordinate; the headings indicate the coordinate system in which
the trajectory history is displayed. The following three columns show the velocity in the same coordinate
system. The final column is the kinetic energy, 1/2 mv”2, for that test charge.

If there are multiple test charges, they will be found further down. Test charges are listed sequentially, and
not side-by-side. Inactive test charges will list only step zero, which gives their initial position and velocity.

The coordinate system used is the one in effect when the save was done.
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Viewing the Current Activity Log

[®; EMSim Activity Log
Edit  Prnt

EtdSim - Electrodynamic simulation Yersion 1.0.5 has started ... ;l
Loading Simulation fram SpinnersZ.ems
Spinners2.ems ready ta runl

T007 is active

TO0Z is active

EO0T ig active

EO0Z iz active

hOOT ig active

TOO01 (162 0.1000 (r.@2): |(1.0113333326616, 28.4274021622145%, -0.333143876944415))| = 1.06479
TOO2 (1362 0.1000 (r@.2): |(1.01133799469062, 208.427306347725° 0.333143844834218 )| = 1.0647¢
TOOT (10& 0.2000 (r@.2): |( 1.054867 7096207 4, BR 4937484268176, -1.30450196354112)| = 1. 67763
TOOZ (138 0.2000 (r.@.2): |( 1.0548827 3400468, 235 4930941 26238°. 1.30450141803182 )| = 1.67764;
TOOT (108 0.3000 fey2): |(0189RRZBIEA32825, 1.06884099027739, -3.06897702097004 )| = 3.2553
TOOZ (1368 0.3000 Gy 2): |(-01896978898R8237, -1 0680RB2R84R222, 3. 06R97204062316 )| = 3,255
TOOT (108 0.4000 (ey2): |(0.220268061470358, -1 135RE7923244817, -4 9285457R763692 )| = B.0OG2:
TOOZ (108 0.4000 fey2): |(-0.220194461500119, 1.13564457643807, 4.92861838145444 )| = 5 062k
TOO1 (1)& 0.5000 (r@theta): |( 3.972093R7699692, 289 081819311218, 138.7549081112177) = 3.97
TOOZ (138 0.5000 (r@ theta): |( 3.97216190120003, 109.078136727247°. 41 24458117453767)| = 3.97
TOO1 (138 0.6000 (r@ theta): |( 3 6AE7A04200R996, 292 35R4E1835108°, 117 409086031 6487)| = 3 BE
TOOZ (138 0.6000 (r.@ theta): |( 3 6ARE42E0431288, 112 352183705369°, 62 RA028972814017)| = 3 BE

.

The activity log can be selected by pressing the "Log" tool bar button, or via the "Display Activity Log" option
of the Edit menu (press ~L). This action will cause the activity log window to conform to the width and
location of the simulation control panel. Select Clear Activity Log from the Edit menu (press ~C) to clear
the activity log.

Besides some general status messages concerning the status of operations, the location of each test charge
is reported after the completion of each simulation run. If you want to examine the results after each step,
view the trajectory history, or press "Step" repeatedly.

The simulation step information includes the test charge identifier, the integration mode in parentheses (1 or
4), then an '@’ followed by the elapsed time. The current coordinate style is then given, followed by the
location coordinates, and finally the distance from the origin is given. When the coordinate system includes
angles, the ° symbol indicates degrees; otherwise radians are being used. Several of these features are
shown in the above screen capture.

The information in the activity log is useful during the development of a simulation. If you wish to save the
contents of the activity log, choose the "Copy All" option of the Edit menu (press ~A); you can then insert the
text into any open document. This includes all items in the log, even those which have scrolled off of the
screen. The Print menu option only prints the portion of the log currently visible on the screen (press "P).

Analytical work is best done from the trajectory history file.
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Viewing the Current Simulation Trajectories:

The trajectory viewer window can be selected by pressing the "Viewer" tool bar button, or via the "View
Simulation” option of the Viewer menu (press *V). Other options include Grids (press *G) which indicates
the XY, YZ, and ZX planes, and Box (press "B) which draws a reference cube, with the positive Z end
colored blue (North Pole), and the negative Z end colored red (South Pole).

[} EMSim Viewer - 5pinners2 [_ O]
Print  Center Beplot Gol

—Arena Size:

m_nnj]

—Yiewer Distance:

2ﬁ_ﬂﬂj|

—FPolar%iew —
' Maorh
= South

The view ball is used to select viewing angles; its center is also the center of the simulation coordinate
system. Perspective projection is used, based upon the viewer's location on the view ball. Viewer distance
is the effective radius of the view ball. If you save the simulation, all current viewing options are also saved.

You can make the center of the view ball image either the North Pole (positive Z), or the South Pole

(negative Z). Any angular position can be obtained; your longitude and co-latitude are shown in the upper
left corner of the view ball image.
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Arena size establishes the effective radius of the simulation, and the scale factors for the viewing area; if you
set it too small, your particles are likely to leave the simulation, causing those particles to be de-activated,
and the simulation will stop. But if you make it too large, you won't be able to see any of the details.

The Print menu option (press Alt-P) causes the entire viewer screen to be printed.

The Center menu option (press Alt-C) reestablishes viewing from directly above the North Pole.

The Replot (press Alt-R) menu option causes the graphics to be completely redrawn; you can also click on
the viewing area. As all graphical updating is automatic, you shouldn't need to use this.

The Go! menu option (press Alt-G) causes the simulation to run the established number of steps, and the
trajectory view to be automatically updated.

Note:

The simulation shown here is Spinners2.ems, which consists of two interacting charged particles, one
assigned the color red, the other green. A widening of the trajectory lines marks their current locations. A
magnetic field is active, and is shown in black: the central axis and four parallel lines. Additional fixed
charges are blue and orange; they show up as large dots because their pixel width has been set to 5.

The Box option has been turned on; this can help orient you to the image.

Note that you can temporarily remove any particle by setting its line style to invisible.
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3D Graphics Theory

Perspective Projection onto Viewer Plane

The 3D simulation trajectory coordinates are projected onto the screen viewing area (viewport) by means of
a perspective transformation, which is derived from the properties of similar triangles. If the viewport has an
XY coordinate system, with origin in the center, then a given simulation point (X, Y, Z) is projected to a
viewport point (Xs, Ys) by means of the following transformation:

Xs = Vsx * (ViewerDistance/ArenaSize) * (X/Z) + Vsx
Ys = Vsy * (ViewerDistance/ArenaSize) * (Y/Z) + Vsy

Where ViewerDistance and ArenaSize can be set by the user; Vsx Vsy are the viewport width and height in
pixels.

Since 3D lines project to 2D lines, it is sufficient to project the endpoints of any line segments, and draw 2D
lines between them.

Rotation of Viewer Plane

If a line extends behind the viewer, it is clipped at the viewing plane, and the exit and entry points through
the clipping plane are connected. This shows as lines running along the edge of the viewport. The most
complete views are those where the viewer distance exceeds the used portion of the simulation arena.
Perspective distortion is apparent whenever the viewer distance is too small.

The above description assumed that the simulation (X, Y) coordinates are horizontal and vertical with
respect to the viewport, and the Z coordinate represents depth. The user is allowed to select alternative
views in terms of position upon a view finder ball, specified as co-latitude (] , (polar angle) and longitude f ,
(azimuth). The simulation coordinates are then transformed so that the viewer's specified location is brought
to the viewport (or equivalently, that the viewport is carried to the viewer's specified location).

The transformation is builtupas T=R,(y ) R, (@) R,( ), where y =-( is the third Euler angle. The
actions to take are as follows: rotate about the Z-axis by our longitude, | ; then rotate about the new Y-axis

by our co-latitude,q . The third angle, Y , is required to remove tilt from the object.

View Ball Operation

A click on the view ball is read as an (X, Y) coordinate within that viewport, which has a half-width of R. If

X2+Y?£R? , We can assume that this (X, Y) is a projection of the view ball onto a plane, and using
the full equation for a sphere of radius R, we solve for Z.

Then if we have normalized the coordinates with the radius of the sphere, the co-latitude is

g = ArcCos (Z), ranging from 0 to 180°, and longitude is ] = ArcTan(Y / X), ranging from 0 to
360°.
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